Jump to content

Bluetooth e Fenvi HB1200


Roran90

Recommended Posts

Mi √® arrivata finalmente la Fenvi HB1200 (in 10 giorni dalla Cina¬†ūü§©), per√≤ ho un problema: il wi-fi funziona oob come mi aspettavo, mentre il bluetooth¬†viene nemmeno rilevato, infatti nei toggle la voce bluetooth √® su off e se vado nelle preferenze mi dice che non √® disponibile.Ho collegato correttamente l'alimentazione usb alla scheda, infatti su windows 10 funziona sia wifi che bluetooth, per cui ho cercato un po' in rete e sembra che vada mappato e abilitato l'header usb a cui ho collegato la Fenvi, per√≤ il fatto √® che io ho gi√† un SSDT patchato con la guida di @Gengik84¬†e anche provando una porta per volta ad attivare una di quelle che erano disattivate, non sembra cambiare nulla, come posso fare? √® possibile che gli header usb 2.0 interni non siano HSxx ma hanno un'altra sigla?

Link to comment
Share on other sites

  • Administrators

Ciao, avevi fatto la mappatura delle usb?

il BT è nelle porte HSxx

da windows vai in gestione periferiche, BT poi nel men√Ļ a tendina vai e cerca il percorso

devi trovare facilmente la usb relativa 

Link to comment
Share on other sites

Si, avevo fatto la mappatura delle porte, ma soltanto quelle dietro la scheda madre e quelle frontali del case, ulteriori header usb sulla scheda madre a cui non era collegato nulla non li avevo mappati.Comunque sia da Windows ho visto che la scheda bluetooth me la da su Port 0003 e Hub 0003 per cui ad intuito mi viene da pensare che sia la rispettiva porta HS03 sull'SSDT, attualmente sulla HS03 veniva riportato TUPC(0x0A), ora l'ho modificato in GUPC(One) visto che come Type quel metodo gli passa 0xFF, però non va ugualmente.Ho sbagliato qualcosa?

Link to comment
Share on other sites

Come percorsi mi da questi:

 

PCIROOT(0)#PCI(1400)#USBROOT(0)#USB(10)#USB(3)
ACPI(_SB_)#ACPI(PCI0)#ACPI(XHC_)#ACPI(RHUB)#ACPI(HS10)#USB(3)

 

Ho abilitato con GPUC(One) la porta HS10 ma non va ugualmente.

Link to comment
Share on other sites

Perché non è corretto in quel modo? TUPC a differenza di GUPC che setta a 0xFF il Type, permette di abilitare la porta passandogli un Type custom (quello per la porta Type c è 0x0A) e visto che SS03 è la porta usb c dietro ed utilizza TUPC(0x0A), ho lasciato lo stesso anche su HS03, com'era fino a prima delle modifiche di oggi.

Link to comment
Share on other sites

Si, il bluetooth su HS10 utilizza GUPC(One) che imposta 0xFF come type, cos√¨ come per tutte le altre porte usb attive, questo √® corretto? Io ho seguito la tua guida per la mappatura, per√≤ in effetti su una guida di un altro utente qui sul forum c'era una tabella con tutti i valori possibili per il type.¬†√ą¬†un problema se tutte¬†le porte attive utilizzano 0xFF (per√≤ nella tua guida non se ne parla di type differenti) oppure sarebbe meglio specificare il type corretto per ogni porta?¬†

 

EDIT: @Gengik84 perdonami ma ho visto ora che la guida era stata aggiornata a Febbraio 2020, io l'avevo seguita molto prima.Quindi mi consigli di mettere la patch e specificare il type per ogni porta invece di lasciare 0xFF su tutte?

Edited by Roran90
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing ¬†¬†0 members

    • There are no registered users currently online
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.